Mystery solved: acoc breaks Wine's configure!

Dan Kegel daniel.r.kegel at
Fri Oct 21 17:44:20 CDT 2005

Here's the strangest thing I've seen for a while.
I was tracking down why I could build Wine, but another guy
on the same machine could only build a slightly broken Wine that
gave the error
  Wine cannot find the FreeType font library.  To enable Wine to
  use TrueType fonts please install a version of FreeType greater than
  or equal to 2.0.5.
whenever you tried to use it.

The first clue was funny output from Wine's configure script,
though it was hard to see until I diff'd against good output,
and used cat -v to make invisible chars visible:

--- configure.log.good.txt   2005-10-20 10:57:21.000000000 -0700
+++ configure.log.bad.txt   2005-10-21 14:41:59.000000000 -0700
-checking for ldd... /usr/bin/ldd
-checking for -lX11 soname...
-checking for -lXext soname...
+checking for ldd... /home/mmoss/bin/ldd
+checking for -lX11 soname...^[[0m
+checking for -lXext soname...^[[0m

And what's that funny ldd?
And what are those escape sequences?
Turns the ldd is one wrapped by acoc (
which colorizes the output, which also explains the funny escape sequences.
This error went away when we stopped using acoc to colorize the
output of commands like ldd.   We had been using acoc-0.5.2,
but the latest version (0.7.1) also exhibits the problem.

I hope this helps somebody else who's scratching their head
over strange build failures!
- Dan

More information about the wine-devel mailing list