Knights and merchants (valgrind)

Joris Huizer jorishuizer at
Sat Apr 15 08:27:14 CDT 2006


As suggested earlier on the list, I ran this game with valgrind (at last 
I tried again with svn, which works better than trying to patch 3.1.1)
There are a few problems: valgrind comes with loads of errors, but only 
indicates which file (*.so) the errors come from (so I need to compile 
wine with gdb debugger support, without optimisations, I guess?)

More serious, it seems wine uses some feature currently not supported by 


x86toIR: unimplemented feature

vex: the `impossible' happened:
    x86 segment override (SEG=CS) prefix
vex storage: T total 1908936388 bytes allocated

valgrind: the 'impossible' happened:
    LibVEX called failure_exit().
==14207==    at 0xB00170DB: (within 

sched status:

Thread 1: status = VgTs_Runnable
==14207==    at 0x480D03: ???

Thread 3: status = VgTs_WaitSys
==14207==    at 0x200546A1: (within /lib/tls/
==14207==    by 0x202E81B7: (within /usr/local/lib/wine/

Thread 4: status = VgTs_WaitSys
==14207==    at 0x20129523: poll (in /lib/tls/
==14207==    by 0x23F252EF: (within /usr/local/lib/wine/

Thread 5: status = VgTs_Runnable
==14207==    at 0x2011D347: sched_yield (in /lib/tls/
==14207==    by 0x23F252EF: (within /usr/local/lib/wine/

Thread 6: status = VgTs_Runnable
==14207==    at 0x219840BE: (within /usr/local/lib/wine/
==14207==    by 0x23F252EF: (within /usr/local/lib/wine/

Note: see also the FAQ.txt in the source distribution.
It contains workarounds to several common problems.

If that doesn't help, please report this bug to:

In the bug report, send all the above text, the valgrind
version, and what Linux distro you are using.  Thanks.


is there a patch for this one?

at least I will recompile wine with gdb debugger support and look at the 
errors valgrind comes with



More information about the wine-devel mailing list