Invisible fonts - unimplemented SPI_GETFONTSMOOTHINGTYPE

Vik Kumar vik at
Sat Jan 7 20:15:09 CST 2006


Looks strikingly similar to the label issue with Poser I'm looking at.
I haven't had a chance to look at it deeper, but I think the issue lies
somewhere in the CreateDIBSection -> DoCopyDIBSection areas.

Would you be so kind to post the gdi+ sample executable somewhere? I'd
like to compare traces and see if we're hitting on the same issue
here.(Tried compiling myself, but VC6 seems to hate the new platform SDK
;-) )


> After some more investigations, it seems like this is a GDI+ problem.
> I've tried a very simple GDI+ demo
> (, which
> draws a line, ellipse and a rectangle. The, I added this text output,
> copied directly from
> FontFamily fontFamily(L"Times New Roman");
> Font font(&fontFamily, 24, FontStyleRegular, UnitPixel);
> PointF pointF(30.0f, 10.0f);
> SolidBrush solidBrush(Color(255, 0, 0, 255));
> graphics.DrawString(L"Hello", -1, &font, pointF, &solidBrush);
> This works perfectly in Windows, but with Wine, no text appears! See
> screnshot versus
> It seems very strange to me that such a basic concept like drawing a
> string with GDI+ doesn't work with Wine. Isn't this a common task?

More information about the wine-devel mailing list