ddraw: ddrawmodes test failures (all platforms)

Paul Vriens paul.vriens.wine at gmail.com
Sat Jan 26 07:00:40 CST 2008

Stefan Dösinger wrote:
> Am Samstag, 26. Januar 2008 13:20:44 schrieb Henning Gerhardt:
>> Am 01/26/2008 12:50 PM schrieb Stefan Dösinger:
>>> Am Samstag, 26. Januar 2008 12:05:09 schrieb Reece Dunn:
>>>> Hi,
>>>> Looking at the ddrawmode test failures, they are because the test is
>>>> checking that if the DDSD_REFRESHRATE flag is set, then dwRefreshRate
>>>> is not 0. However, on many of the test platforms at
>>>> http://test.winehq.org/data/200801161000, they are reporting a refresh
>>>> rate of 0.
>>>> Are these bogus - due to them running on VM - or is this a valid case?
>>>> I don't currently have the ability to build those tests locally, so I
>>>> cannot verify those failures.
>>> I have never seen such failures on my real hardware(Windows XP or Vista),
>>> so I think they fail due to VM drivers. I'll re-run the tests to make
>>> sure the tests didn't break somewhen.
>> I don't think so. My system (called xanlosch) is a real XP system with
>> an ATI Mobility 9700 graphic card with one of the latest ATI drivers
>> (7.11er catalyst drivers). Maybe an ATI driver issue?
> If the ATI driver behaves that way then I think our tests should accept this 
> behavior
> I have a radeon 9000 mobility, and I don't remember any test failures
Just ran the test on my real WinXP box (NVIDIA GeForce FX 5200) with the same 




More information about the wine-devel mailing list