Latency as of yesterday

Susan Cragin susancragin at
Wed Aug 5 14:13:59 CDT 2009

>>> I got a new kernel and a new git yesterday. 
>>> One of them is causing massive latency in my sound system. I looked at the changes to git that were made yesterday, and suspect that the latency came with the kernel. 
>>> 2.6.31-5-generic is the new kernel. 
>>> Just for "fun" I reinstalled my entire system this morning, and the latency is the same, so it is not due to any tweaks I have made.
>>> I have been running using winecfg's oss sound and padsp for a week or so. It had been working fairly well. 
>>> Anyway, before I file a bug on Ubuntu against the kernel, I thought I would ask if yesterday's git might be at fault. I don't have time to do regression testing before Friday, but I will do it if needed. 
>>> Susan
>>Ubuntu has bugs open for sound issues with the newer kernels.
>>> (Separate issue -- I have not been able to run dragon NaturallySpeaking with alsa for several months. Timeout issues during training.)
>>Is there a bug logged for this?
>Yes and yes. 
>I looked at the bunch of Ubuntu bugs relating to sound with the newest kernel. There was nothing right on point, so I filed on of my own. 
>The alsa bug is:
>Bottom line -- no working sound in wine right now, that I can figure out. At all. 
>In addition, purging pulseaudio has just gotten much more difficult, as of the last couple of days. I tried yesterday. Directions that worked 2 weeks ago now cause desktop to be removed. (I had to re-install system.)

The problem has been identified. Stay tuned. 

>This is probably due to a libasound2-plugins and pulseaudio/rtkit
>skew; the latest libasound2-plugins needs at least pulseaudio
>1:0.9.16~test3 and rtkit 0.3. Karmic has an older version of
>pulseaudio (1:0.9.15) at the moment.

More information about the wine-devel mailing list