Sound on TestBot

Joerg-Cyril.Hoehle at Joerg-Cyril.Hoehle at
Fri Sep 17 07:32:08 CDT 2010

Greg Geldorp wrote:
>I've found a way to add a soundcard to most of the TestBot VMs (using
>the virtual soundcard driver from VMware View).

This is excellent news. It even has MIDI-out!

capture.c:661: found 0 WaveIn devices
means that most mci.c tests (which are mostly mciwave tests) are skipped
because the tests depend on the ability to record, then play back.
mci.c:651: Tests skipped: Please install audio driver. Everything is skipped.

Hopefully Francois Gouget will update his vmware machines with these
drivers (or the ones Paul Vriens' uses) so that the timeouts will disappear.

Earlier this year, Julius Schwartzenberg found out that the timeouts in
winmm tests on vmware could be avoided by installing another driver.

capture.c:674: Test failed: waveInGetDevCapsA(WAVE_MAPPER): got MMSYSERR_NOERROR
capture.c:691: Test failed: waveInGetDevCapsW(1): got MMSYSERR_NOERROR
Weird. waveOutGetDevCaps (in wave.c) behaves as expected. Looks like a driver bug.

Perhaps one explanation for the WAVE_MAPPER case is found in my mci.c tests:
     * However some w2k8/w7 machines return no error when there's no wave
     * input device (perhaps querying waveOutGetNumDevs instead of waveIn?),
     * still the record command below fails with MCIERR_WAVE_INPUTSUNSUITABLE.
     * Don't skip here, record will fail below. */
    err = mciSendString("set x format tag pcm", NULL, 0, NULL);

I should feed testbot a patch to call wave_in_test_device(1)
despite numdevs=0 to see what happens.

 Jörg Höhle

More information about the wine-devel mailing list