msvcrt: Partially implement _set_abort_behavior

Detlef Riekenberg wine.dev at web.de
Tue Jan 11 22:56:55 CST 2011


On Mi, 2011-01-12 at 00:48 +0300, Nikolay Sivov wrote:

> Date: Wed, 12 Jan 2011 00:46:26 +0300
> Subject: [PATCH 1/1] Partially implement _set_abort_behavior

Please search the patches queue first.
try 2: http://source.winehq.org/patches/data/70231
try 1: http://source.winehq.org/patches/data/70136

 
> +static int MSVCRT_abort_behavior =  MSVCRT__WRITE_ABORT_MSG |
> MSVCRT__WRITE_CALL_REPORTFAULT;

- _set_abort_behavior get unsigned int, but you use an int. Why?
- mingw header have the same name as msdn.
  Why are you using different names?

>  /*********************************************************************
> + *             _set_abort_behavior (MSVCRT.@)
> + *
> + * Not exported by native msvcrt, added in msvcr80
> + */
> +int CDECL MSVCRT__set_abort_behavior(int flags, int mask)
> +{

- need unsigned int


> diff --git a/dlls/msvcrt/msvcrt.h b/dlls/msvcrt/msvcrt.h
>  
> +/* _set_abort_behavior codes */
> +#define MSVCRT__WRITE_ABORT_MSG        1
> +#define MSVCRT__WRITE_CALL_REPORTFAULT 2
> +
> +int __cdecl MSVCRT__set_abort_behavior(int,int);

- correct location is stdlib.h
- names are wrong
- need unsigned int

> 
-- 
By by ... Detlef






More information about the wine-devel mailing list