comdlg32: Use SetRect() instead of open coding it.

Frédéric Delanoy frederic.delanoy at gmail.com
Wed May 4 05:31:16 CDT 2016


On Wed, May 4, 2016 at 10:55 AM, Dmitry Timoshkov <dmitry at baikal.ru> wrote:
> Frédéric Delanoy <frederic.delanoy at gmail.com> wrote:
>
>> -        cancel_rc.left = dialog_rc.right - cancel_width - hspacing;
>> -        cancel_rc.top = dialog_rc.bottom - cancel_height - vspacing;
>> -        cancel_rc.right = cancel_rc.left + cancel_width;
>> -        cancel_rc.bottom = cancel_rc.top + cancel_height;
>> +        SetRect(&cancel_rc,
>> +                dialog_rc.right - cancel_width - hspacing, dialog_rc.bottom - cancel_height - vspacing,
>> +                dialog_rc.right - hspacing               , dialog_rc.bottom - vspacing);
>
> This is at least very strange and weird formatting of an API call.
> I don't see anything like that in the changed file.
>
> --
> Dmitry.

It's for increased readability. Of course, it doesn't show well in
proportional fonts like those used in emails.

-- 
Frédéric



More information about the wine-devel mailing list