[PATCH 5/9] d3dx9: Store effect creation flags in struct d3dx_base_effect.

Paul Gofman gofmanp at gmail.com
Thu Apr 27 17:35:38 CDT 2017


On 04/28/2017 01:30 AM, Matteo Bruni wrote:
> 2017-04-27 13:05 GMT+02:00 Paul Gofman <gofmanp at gmail.com>:
>> Signed-off-by: Paul Gofman <gofmanp at gmail.com>
>> ---
>>   dlls/d3dx9_36/effect.c | 8 +++++---
>>   1 file changed, 5 insertions(+), 3 deletions(-)
>>
>> diff --git a/dlls/d3dx9_36/effect.c b/dlls/d3dx9_36/effect.c
>> index c2fb1d0..7885241 100644
>> --- a/dlls/d3dx9_36/effect.c
>> +++ b/dlls/d3dx9_36/effect.c
>> @@ -154,6 +154,7 @@ struct d3dx9_base_effect
>>       struct d3dx_object *objects;
>>
>>       struct d3dx_effect_pool *pool;
>> +    DWORD flags;
>>   };
>>
>>   struct ID3DXEffectImpl
>> @@ -169,7 +170,7 @@ struct ID3DXEffectImpl
>>       struct d3dx_technique *active_technique;
>>       struct d3dx_pass *active_pass;
>>       BOOL started;
>> -    DWORD flags;
>> +    DWORD begin_flags;
> begin_flags is quite ugly IMO. If you really want to change it from
> just flags, maybe call it creation_flags.
>
>
But they are not creation flags, that's why I wanted to change the name, 
as otherwise we would end up having 'flags' in ID3DXEffectImpl and same 
'flags' in 'd3dx9_base_effect'. Those flags in ID3DXEffectImpl are the 
flags passed to effect Begin() function, not to the effect creation. 
Maybe rename them to effect_begin_flags then?




More information about the wine-devel mailing list