winegstreamer: Avoid Fedora and openSUSE?

Paul Gofman pgofman at
Sun May 24 10:19:43 CDT 2020

On 5/24/20 17:22, Francois Gouget wrote:
> That's very surprising. I tested this on Fedora 32 yesterday and the bug 
> was definitely still present.
Admittedly, my comment of being unable to reproduce the referenced bug
was misleading, I actually never tried installing distro-provided 32-bit
client tools, only libraries. My reply was concerning winegstreamer
> Are you sure these are 32-bit games and that they use winegstreamer.dll?
> How can winegstreamer find the 32-bit plugins if gst-plugin-scanner 
> cannot even load the plugin libraries?
Yes, the first example out of my head is Blaz Blue Calamity Trigger from
Steam which I was testing. It is 32 bit and winegstreamer definitely
worked here. There was a problem with missing sound when playing movie
which I debugged but that was not related to gstreamer, and MPEG video
was playing OK.
> Or maybe the 32-bit GStreamer plugins work but not the 64-bit ones...
> What do you get for these commands:
>   rpm -qf /usr/libexec/gstreamer-1.0/gst-plugin-scanner
>   rpm -qf /usr/bin/gst-inspect-1.0
>   gst-inspect-1.0 videoconvert | grep Filename

$ rpm -qf /usr/libexec/gstreamer-1.0/gst-plugin-scanner


$ rpm -qf /usr/bin/gst-inspect-1.0

$ gst-inspect-1.0 videoconvert | grep Filename
 Filename                 /usr/lib64/gstreamer-1.0/

(all that is apparently 64 bit stuff, I didn't ever install 32 bit distro provided gst client tools manually).

More information about the wine-devel mailing list