[PATCH 3/3] wined3d: Handle NOOVERWRITE maps on persistently mapped Vulkan buffers from the client thread.

Zebediah Figura zfigura at codeweavers.com
Sun Oct 10 22:57:07 CDT 2021


On 10/8/21 11:29 AM, Henri Verbeet wrote:
> On Fri, 8 Oct 2021 at 18:24, Henri Verbeet <hverbeet at gmail.com> wrote:
>>> +struct wined3d_client_sub_resource
>>> +{
>>> +    struct wined3d_bo_address addr;
>>> +
>>> +    struct upload_bo upload_bo;
>>> +    struct wined3d_box upload_box;
>>> +};
>>> +
>> I'm tempted to think we want to track this per resource instead of per
>> sub-resource. For buffers it doesn't really matter though, and for
>> textures we don't implement it yet. Perhaps we should just leave
>> textures alone for now? That would also avoid
>> wined3d_resource_get_client_sub_resource() for the moment.
> 
> Also, how does "addr" relate to "upload_bo.addr", and e.g.
> "buffer_object" in the case of buffer resources? I can figure it out
> by reading the patch, but could it perhaps be made more obvious when
> reading the structure definition?
> 

Hmm, I don't immediately see a nice way to change the field names. I 
guess I'd rename the latter two members to "mapped_bo"/"mapped_box", 
although that's not really unambiguous either.

It could probably at least do with some comments in the struct definition.



More information about the wine-devel mailing list