Successful compile of Wine

cfk at cfk at
Sun Mar 11 16:59:58 CST 2001

Let me try to amplify my question a bit. First, I am running Wine on a
computer with no windows installed. Just Rh6. I can ftp windows programs
from one of the other machines on my network. I am trying to build up my
understanding from the simplest windows executables so I can work on
figuring out how things are going awry. The computer I'm using is just
running VGA, no fancy SVGA or any trick video stuff. First, I have copied a
few programs from a w2k machine onto this computers /c/windows and I have a
/c/windows/system in it. I can run notepad.exe, calc.exe and welcome.exe.
When I try to run sol.exe or freecell.exe, wine can't find cards.dll even
though cards.dll is in the same directory (the one I am executing from),
which is /c/windows. I tried WINEDLLPATH=/c/windows, and I tried putting
cards.dll into /c/windows/system and changing the WINDELLPATH. So, the
question of the afternoon is "why can't wine seem to find a dll that is in
the same directory as the executable?"

<g.patel at> wrote in message
news:3aabe421.1280934 at
> On Sun, 11 Mar 2001 12:30:57 -0800, <cfk at> wrote:
> <snip>
> >and they still complain and don't run. And lastly, I am trying to run
> >codewright (that of course is more ambitious then the games) and I can
> >execute CW32.EXE and there is a momentary flash of a window trying to be
> >instantiated and then I am back to my bash shell with no errors on the
> >shell. I tried adding CWbasic.dll from the w2k machine to no avail.
> You can try to install the program - mount the cdrom or whatever
> and run setup.exe or something like that. If the install succeeds
> it would set all the necessary directories/dlls/registry entries at
> the right place.
> Gerard

More information about the wine-users mailing list