Microsoft Home Publishing - 'file could not be opened'

John Mellor John at
Sat Jun 22 07:29:15 CDT 2002

I have managed to run Microsoft Home Publishing with Codeweavers Preview 6 on mandrake 8.2, using my existing Windows installation.  It loads and diplays Ok, I can get the help info and previews pop up for project templates.  All seems well until I try to open a template, a recent project or any .php file from a directory.  In the first two instances I get a box saying the file could not be opened.  In the last the program hangs.  There are no error messages in the log other than 'unhandled exception' in the last case. 
              Early in the loading of the program it does say: 'fixme: file: SetFileAttributesA Couldn't set file attributes for existing file /Microsoft Home Publishing 2000/Hpuk.gdb' . I investigated this through Google, thinking it might be connected to the problem, and found that my /mnt/windows partition might be set to Read Only.  However, I find that every relevant file is rwx for everybody.  To make sure I tried as root but no difference, and I set the /mnt/windows entry in /etc/fstab to umask 000.  Still no joy. 
           I tried with fake windows and could not get it to run at all.  I tried freshly installing Home Publishing from the cd into fake windows  and could not get it to do so. Can anyone help me please?  My wife uses this all the time and it is my final tie to Windows!

More information about the wine-users mailing list