Why can't I be root? Samba needs root.

Bill Holland BHolland at Cornell-Mayo.com
Thu Oct 17 13:33:26 CDT 2002

I think I am caught in a catch-22.

WINE wont install if I am root, and Samba wont work if I am not root.

I am trying to use wineconsole to run Burton's "TLIB" version control
software, which uses SAMBA mounts to access the source files on a Windows

I tried adding my user account to the wheel and root groups, but it still
wont let me lock a file through Samba.

I copied my ~/.wine/* to /root/.wine/* and tried running everything as root.
It worked better (I was able to lock files via samba) but I don't think the
program I am running (tlibe32c.exe) is getting the parameters I am trying to
pass it.

I *was* using the RPM 10/7 version of WINE, but switched to the source
version so I could run "wineinstall".  The RPM version seemed to be lacking
programs (like regapi) and not be as well documented as the source version -
but it did let me be root.  The source version seemed to have be more used,
but wont let me be root.  Wineconsole seems to have rare documentation.  I'm
not using any real windows files, which also seems to be rare.

What is the best way to use WINE to run a command line Windows program?
Which version of WINE should I be using? RPM/TGZ?  WINE/wineconsole?

Any help would be greatly appreciated.


- Bill

More information about the wine-users mailing list