IE6/5.5 installs but no browsing

Andrew Rechenberg arechenberg at
Wed Apr 30 09:59:24 CDT 2003

OK, I've gotten IE6 to install and open with no Windows installation
(other tham DCOM98.exe), and the icons look fine, but I can't browse
anywhere.  I get the "page cannot be displayed" error when trying to
browse any page other than localhost (and sometimes I can't get to
localhost).  I've tried by name and IP.  I can browse just fine with
Galeon so I know it's not a network issue (well it may be a WINE
network issue :) ).

I have the same problem with IE5.5SP2.

Here is the process I went through to install IE6/5.5SP2:

- Install my own WINE RPM based on CVS dated 20030428
- Create ~/.wine
- Add my config (with some additional lines ripped from Crossover
Office 2.0 config)
- Add default WINE registry entries (regedit winedefault.reg)
- Add DCOM98.exe with 'wine dcom98.exe /c' which only extracts the
files and prompts you for an extraction location (I put
- Run 'wine ie6setup.exe'
- Run 'wineboot'

There is an error about AddCRL failing during the setup and an error
loading ieinfo5.ocx during the wineboot phase but otherwise the
installation completes successfully.

When I run 'wine IEXPLORE.EXE' from my WINE c_drive the Internet
Connection Wizard appears and I cancel it and then IE appears but I
cannot browse any sites.  Localhost works sometimes by name but not by
IP.  A packet capture from Ethereal shows that IE is not even
attempting to contact a server or do a name lookup.

I've tried running the ICW separately but it blows up and WINE goes
into debug mode.

Does anyone have any ideas?  Is any other information about my system

Thanks for your help,

PS My system details are below.  There is a URL there where you can
grab my RPMS.  The ones with 'nptl' in the name have been compiled on
RH9 with the '--with-nptl' configure option.  The ones without 'nptl'
are compiled on the system below (RH7.3, glibc 2.2.5-42).  The RPMS
use a spec file based on the one that's included with the WINE RPM for
Red Hat 8.0.  It appears that RH9 rpmbuild strips out debug info.  I'm
not much of a developer but I think that's why the RPM without NPTL is
so much larger.

BTW, I dorked and didn't put winedefault.reg in the RPM so you'll have
to grab that from CVS.  Also you'll have to grab the config separately
and possibly modify it to suite your .wine.  The one in the RPM
doesn't work for IE6.  I'll try to rebuild these RPMS so they include
the proper config and winedefault.reg.

System Specs:

Dell GX100
Celeron 533
Red Hat Linux 7.3 with kernel 2.4.20aa1
wine-20030428-1.i386.rpm (available at

More information about the wine-users mailing list