[Wine]HELP - 'version mismatch' error?

Rich Coco rich.coco at verizon.net
Sun Aug 22 11:38:04 CDT 2004

On a linux RedHat-9 PC, I had wine set up and running fine
(the version that came with the RH distro and perhaps updated
via the RH update service when it used to be available).
For example, I sucessfully ran Xnews on my linux box under wine.

However, certain other windows apps did not work so i thought perhaps
I would update to the latest cvs version of wine (the RH-9.0 version
being well behind the lastest available, plus I understand wine is
improving all the time).
I uninstalled the RH version (using rpm) and manually blew away a
directory I found via 'locate wine': /usr/lib/wine

I then checked-out the latest cvs version (under /usr/local/src/wine)
and ran <wine>/tools/wineinstall. All went well...until I tried to
run the wine client. i consistently get the following error,
no matter what arguments I give it (eg, --help, -help, etc...)

racoco: wine --help
wine client error:9: version mismatch 142/149.
Your wineserver binary was not upgraded correctly,
or you have an older one somewhere in your PATH.
Or maybe the wrong wineserver is still running?

there is no wineserver running. the only wineserver on my hard drive is
the one just built from the wine cvs tree. If I run wineserver
from the commandline I 'see' it (under ps) but still the wine client
complains (yielding the above error msg).

I feel sure the problem has nothing to do with the wine config file.
It seems like there is a library file that wine relies upon that I
also need to update? Altho, running ldd yields:

racoco: ldd wine
        not a dynamic executable

so maybe this bit me at compile-time?

I am at a loss as to what 'version mismatch' wine is complaining about.
the wine FAQ provided no help, so before i give up and re-install the
RH wine RPM, I thought I'd try this forum.

Any advice out there?


- rich

rich.coco at verizon.net

More information about the wine-users mailing list