[Wine]fonts - newbie squared

M-Halo masochisthalo at yahoo.com
Tue Dec 7 13:49:19 CST 2004

I'm not sure if you added more bugs, but honestly, I
don't rely on Wine RPMs because I can never get them
to work properly (although others will swear up and
down that they have no problems with it.)  So, I
install via source.

As far as fonts go, I typically just copy all the
fonts from my REAL c:/windows/system/fonts directory
into my FAKE wine_cDrive/windows/system/fonts

That usually helps tons.  Otherwise, I don't mess with
any other settings.


--- "David L. Smith" <smithfamily at oswego.net> wrote:

> 	Background:
> I run an NT 4.0 installation that also boots to my
> primary Linux (Red Hat 9) 
> sitting on a partition in a second drive. Earlier,
> after installing Red Hat 
> 9, I tried to install wine, but it Had Problems,
> even when I tried some of 
> the solutions. So I waited. Recently, I tried to
> install an updated version 
> of wine using an rpm, so I tried to unstall the old
> stuff. Wouldn't 
> uninstall, and the rpm wouldn't install. So I
> deleted as much as I could 
> figure out was there, verified that the rpm still
> wouldn't install (I assume 
> it is on a database somewhere), downloaded the
> tarball for wine 20041201 and 
> tried to install that. Worked. But did I add bugs?
> 	The problem:
> Fonts stink. Menu fonts stink. More specifically,
> NotePad fonts stunk. Looks 
> like a billboard through a drenched windshield with
> the wipers off. 
> 	conf file
> the conf file has this:
> [fonts]
> "Default" = "-adobe-helvetica-"
> "DefaultFixed" = "fixed"
> "DefaultSerif" = "-adobe-times-"
> "DefaultSansSerif" = "-adobe-helvetica-"
> [FontDirs]
> "dir1" = "/usr/X11R6/lib/X11/fonts/TTF"
> ...
> "dir4" = "/home/david/wine-20041201/fonts/"
> ...
> That last, btw, enabled a few more fonts in the
> Notepad menu, but they 
> continued ugly, but not as much.
> 	Other tries:
>  I tried running "fnt2bdf --help" by going into the
> wine-20041201 folder, but 
> "Corrupt or invalid file." was its answer.
> 	Further interesting facts:
> When I ssh notepad from my Mandrake laptop, I have
> the same problem, but when 
> I run it on the laptop directly, there is no
> problem.
> 	Questions:
> 1. Back to my earlier question. Did I add bugs by
> possibly not cleaning out 
> the old installation?
> 2. Is there a make file of some sort that goes with
> the source code of 
> fnt2bdf?
> 3+. Is this perhaps a problem in Red Hat 9, or X
> windows, or KDE? KDE fonts 
> look fine. If KDE is fine, can I assume that RH9 is
> also? How do I test X 
> windows fonts to see if the problem is there.
> 4. Can I add ntfs directories into the FontDirs? or
> would it try to write to 
> file?
> 5. What additional facts should I supply?
> 6. What obvious thing am I missing? <sigh>
> -- 
> blessings,
> David L. Smith
> _______________________________________________
> wine-users mailing list
> wine-users at winehq.org
> http://www.winehq.org/mailman/listinfo/wine-users

Do you Yahoo!? 
All your favorites on one personal page – Try My Yahoo!

More information about the wine-users mailing list