Sound Problems with Wine and ALSA

Mark Knecht mknecht at
Wed Mar 3 13:15:02 CST 2004

Rick Knight wrote:
> I've been trying to fix this for a couple of weeks now without any luck. 
> I'm hoping someone here can offer some help.
> I Replaced my mainboard and CPU about a month ago. The new board has 
> on-board sound as did my old mainboard, but the new board uses an 
> Intel8x0 sound chip, the old board had a Yamaha YMFPCI chipset. Because 
> of the difference in sound systems I needed to rebuild the ALSA drivers 
> and decided to get the latest from ALSA. This also required a kernel 
> upgrade, from 2.4.20 to 2.6.2. I built and installed the new kernel and 
> the ALSA drivers, got sound working in linux and on my KDE desktop and 
> then tried to get sound from Wine. No luck. I have ALSA configured with 
> sequencer and oss support and everything seems to load properly, but I 
> have no sound at all from Wine. I've just upgraded to ALSA-1.0.3 and 
> Kernel 2.6.3 because of some fixes to the intel8x0 driver in ALSA, but 
> still no sound.
> I use Wine primarily for a couple of Windows games, Unreal (1) and 
> Half-Life and before my hardware upgrade everything worked great, now I 
> get no sound at all. no error message to help me locate the problem and 
> Half-Life complains that the sound hardware is in use by another app but 
> continues to load and play but in complete silence. I've tried using 
> Arts support in wine but that only give music, now sound effects. I've 
> also tried the ALSA support in Wine and that works better, but the sound 
> effects lag the action by about a second. I'm not picky about how I get 
> sound in Wine so almost any solution will work.
> I know there is a way to get this to work because one day about a week 
> and a half ago I actually did get sound from Wine with oss in Unreal. My 
> son and I played Unreal for a couple of hours before turning things off 
> for the night. Next day, no sound in Wine again!
> Thanks in advance,
> Rick Knight
> (rick at
> _______________________________________________
> wine-users mailing list
> wine-users at

    I don't think I have enough information to solve the problem, and I 
may just not be smart enough to help anyway, but let's look into a few 

1) Since you went to a 2.6 series kernel you complicated things a bit. 
The alsa-drivers package is built into the 2.6 kernels, so you need to 
make sure you place your Alsa download for that package in the right 
location and rebuid the kernel after you've done that.

1a) Alternatively, some Gentoo people have reported that they have built
2.6 series kernels and only enabled sound support as modular, and then 
built the complete Alsa package outside of the kernel build.

2) What drivers are you loading? Are they built into the kernel or 
loaded as modules? Provide some modules.conf data and maybe somethign 
will pop up.

3) How do you have the wine config file set of accessing sound? I've 
gotten my best results using OSS in that config file and then loading 
Alsa's OSS Emulation layer.

4) If you're in KDE, then you certainly want to make sure that KDE does 
NOT start Arts or it will grab the sound hardware and Alsa won't work. 
Since you got sound somehow, are you doing that with an Alsa app, like 
alsaplayer, or with some Arts app that comes with KDE?

    I hope these ideas trigger some go results.

Best wishes,

More information about the wine-users mailing list