[Wine]Compiling on AMD64: errors

Hiji hijinio at yahoo.com
Fri Apr 1 11:33:54 CST 2005

The easiest thing to do when compiling Wine is to use
the wineinstall script in the ./[src]/tools/ folder.

Also, I hear that AMD64 fixes have comes in later
versions; you're trying to compile a really old
version of Wine.  Download a newer version. :)


--- M <matt at explodicide.com> wrote:
> I'm trying to compile ver 20041019 (older ver for
> winetools) on my 
> x86_64 Fedora Core 3.  ./configure works fine, and
> so does make depend, 
> but when it comes down to actually compiling, it has
> a hard time 
> locating the right libs to link against. 
> ../../../tools/winegcc/winegcc
> -B../../../tools/winebuild -shared 
> ./winearts.drv.spec    arts.o audio.o 
> winearts.drv.dbg.o   -o 
> winearts.drv.so -L../../../dlls  -lwinmm -luser32
> -lkernel32 
> -L../../../libs/wine -lwine -L/usr/lib64 -ldl
> -lartsc -lpthread 
> -lgmodule-2.0 -ldl -lgthread-2.0 -lglib-2.0 -ldxguid
> -luuid 
> -L../../../libs/port -lwine_port
> /usr/bin/ld: skipping incompatible
> /usr/lib64/libartsc.so when searching 
> for -lartsc
> /usr/bin/ld: cannot find -lartsc
> collect2: ld returned 1 exit status
> winegcc: gcc failed.
> It actually gave a similar error at one point before
> this about 64-bit X 
> libs, but rerunning ./configure with  the
> --x-libraries=/usr/X11R6/lib 
> option and then building worked for that.
> I've had this issue a lot with code not knowing how
> to use the right 
> arch libs (though usually it's a problem I resolve
> by using the 64 bit 
> libs, not the 32 bit ones.)  I usually just manually
> re-run the last 
> compile command, after changing it to use
> /whatever/lib64 instead of 
> /whatever/lib and that fixes it enough for the
> `make` to continue.  In 
> this case, rerunning that last command gives the
> same errors, even if I 
> change the command-line option '-L/usr/lib64' to
> '-L/usr/lib,' and the 
> errors claim that it's still looking in /usr/lib64
> and finding the 
> incompatible libs.  I tried changing all of the
> pertinant Makefiles to 
> point to /usr/lib, but only the Makefile in
> tools/wndlls/xmaketf 
> actually had the reference to /usr/lib64, and
> changing that had no 
> impact on the build or error.
> I tried running `linux32 ./configure` to see if that
> took care of the 
> lib issue, but that made things go very, very
> poorley with the compile.  
> Errors everywhere.
> So how can I tell it to use the 32 bit libs
> properly?
> ~M~
> _______________________________________________
> wine-users mailing list
> wine-users at winehq.org
> http://www.winehq.org/mailman/listinfo/wine-users

Do you Yahoo!? 
Yahoo! Personals - Better first dates. More second dates. 

More information about the wine-users mailing list