[Wine]Trouble with X under Fedora Core 3

Bernhard Krickl krickl at riege.com
Wed Jan 19 03:47:37 CST 2005


I have tried several ways to get wine up and running on my Fedora Core 3 
machine. I used pre-built FC3 rpm's from 20050111 as well as some older and also 
tried compiling from SRPM for FC3 or from tarball. I have tried to run some 
programs, namely notepad.exe from a WinXP, draw4ch2.exe which is an installer 
for a program which works from Win95 upwards, and the dcom98.exe which 
frankscorner.org advises to install. The error I get is always the exact same 
four lines:

X Error of failed request:  BadMatch (invalid parameter attributes)
   Major opcode of failed request:  1 (X_CreateWindow)
   Serial number of failed request:  20
   Current serial number in output stream:  27

I can only assume that Wine is having trouble with the Xorg Server. Has anybody 
else experienced this problem? Or maybe even found a solution apart from 
replacing the Xorg server?

best regards,
Bernhard Krickl.

More information about the wine-users mailing list