[Wine]Instal FC PPO

Rickard B Hansson r.b.h at swipnet.se
Fri Jul 15 12:03:51 CDT 2005


I just ´cant get FCPPO (FirstClassPersonalPostOffice) installed.

The FC client (8.005US.exe), installs ok. 
When installing fcpers80231.exe, I get info that
"This version of windows is not supported.", right after I accept the
license agreement.

I have to kill wineserver to be able to continue work.
The console window has following info:

rbh at chief:/data1/download/FileShare/Internet/FirstClass> wine FCPERS80231
fixme:crypt:CRYPT_VerifyImage (rsabase.dll, 0x403e8b98): not verifying 
image fixme:win:SetWindowTextA cannot set text "FirstClass\xae Setup" of 
other process window (nil) fixme:crypt:CRYPT_VerifyImage (rsabase.dll, 
0x403e9068): not verifying image wine: Unhandled exception (thread 000b), 
starting debugger...
WineDbg starting on pid 0xa
Unhandled exception: page fault on read access to 0x7ca04ca3 in 32-bit code 
In 32 bit mode.
Register dump:
 CS:0073 SS:007b DS:007b ES:007b FS:003b GS:0033
 EIP:404e2e38 ESP:406fdc38 EBP:406fdc9c EFLAGS:00210206(   - 00      - RIP1)
 EAX:00000001 EBX:40583a88 ECX:00000001 EDX:7ca04ca3
 ESI:ffffffff EDI:7ca04ca3
Stack dump:
0x406fdc38:  00000073 00000000 401f8c00 406fdce4
0x406fdc48:  00000000 406fdd28 40087574 406fff38
0x406fdc58:  7010a6dc 70146fb8 ffffffff 406fdd4c
0x406fdc68:  401bb11e 406fdc94 00000002 00000001
0x406fdc78:  00000001 00000000 00000000 40058324
0x406fdc88:  8000001a 00000000 40583a88 406fdd98
=>1 0x404e2e38 INSTR_EmulateInstruction in kernel32 (0x406fdc9c)
  2 0x4052ac9c in kernel32 (+0x7ac9c) (0x406fdcb8)
  3 0x401b6149 EXC_RtlRaiseException in ntdll (0x406fdd68)
  4 0x401d51cc in ntdll (+0x351cc) (0x406fdd84)
  5 0x401dfb40 __wine_call_from_32_restore_regs in ntdll (0x406fe0e0)
  6 0x1001ae76 in setup (+0x1ae76) (0x406fe930)
  7 0x00408b6f in fcpers80231 (+0x8b6f) (0x406ff30c)
  8 0x004077a9 in fcpers80231 (+0x77a9) (0x406ffec0)
  9 0x0040ccec  ??  in fcpers80231 (0x406fff20)
  10 0x40505652 in kernel32 (+0x55652) (0x406ffff4)
  11 0x40039de1  ??  in libwine.so.1 (0x00000000)
0x404e2e38 INSTR_EmulateInstruction+0xc8 in kernel32: movzbl    0x0(%edi),%edx
Wine-dbg>rbh at chief:/data1/download/FileShare/Internet/FirstClass>    

Os: Suse 9.3. wine 20050211-4 (installed from rpm for suse)

Tried to downgrade wine to 20041019-0.1 but get the same result.
  winetools-210jo-5 with windows-installer

Any suggestions?

If it is impossible to install FC PPO is it possible to just edit the
registry (and maybe copy some files to windows directory? (The postoffice
is alreadey installed on an sambashare, but it would be nice not to be
forsed reading from winxp wkst)
// Regards rbh

More information about the wine-users mailing list