[Wine] Three simple problems with wine under SuSe 9.3

G4BBH at Winlink.org G4BBH at Winlink.org
Tue Oct 4 16:58:00 CDT 2005

I have three problems with wine. Wine set up a pseudo windows directory system under my home directory/wine.  My application resides in the created 'Program Files' directory and a necessary file placed in the windows/system directory.

1.  If I click on the exe and run with wine it works without error.  However I seem unable to set up a path to the exe as in 'wine "drive_c/Program Files/Airmail/Airmail3.exe"' as the executive can never be found.  I tried all sorts of path combinations and failed.

2.  My application starts with all the wrong fonts.  I copied over a basic set of Windows fonts to my pseudo windows/fonts directory and it is much better now.  Are there limitations to using those fonts?

3.  And the most seriously prom: my application required to talk to radio equipment and a special modem via com ports.Even if I select com1 it comes back and says it is already in use (it isn't).  If I run wine as super user then com1 works but I lose some default paths and end up losing my fonts and the application can't find a file in windows/system.  The dos devices directory shows com1 as a link to ttyS1.  I suspect I need to change permissions.  All my other com ports are actually on a USB hub. How can I set up at at least 3 com ports (radio, gps and modem each require a com port with standard handshaking).  Do I set up (say) com5 as a link to the first USB port device?

I never had any problems with VMWare but that defeats the object of trying to ditch Bill Gates products........


More information about the wine-users mailing list