[Wine] Problems installing Watchguard Firebox System software in wine (installshield)

Randall Walls rwalls at gwi.net
Mon Oct 10 21:21:09 CDT 2005

Any chance you can upgrade that wine install to 20050930? I don't know 
if Gentoo has this package in their repository, but if all else fails 
you could always try a compile from source. There have been patches 
against the wine tree that relate to some of the DCOM work that has been 
going on, and this may get you a bit past where you are. There are a 
number of hits through google for 'Watchguard WFS wine linux' where 
people have claimed that it can be done (WFS on Linux using Wine) but no 
mention of which version.

Having the dlls in system32 and just linking to system should be fine. 
Out of curiosity, did you try an install before doing all the DCOM98 
stuff? I'd be curious to see if wine provides any more output for you 
than the single line message that it is returning right now. Normally 
you would get a good deal of feedback in the terminal that should give 
you SOMETHING to go on. I would try the install with a straight $wine 
app.exe and from there we may be able to figure where it is failing and 
then determine what, if any, native dlls need to be used.

Randall Walls

Kevin Hanser wrote:

> Hello,
> I am trying to use WINE (20050725-r1 on Gentoo Linux) to install/run 
> Watchguard's Firebox Management Software (WFS).  The WFS installer 
> uses an installshield installer of course..  I've been looking thru 
> the FAQ, wiki, etc and have found info about DCOM98 needing to be 
> installed.  I've tried a bunch of things so far, and here's where I 
> stand:
> First, I tried getting DCOM98 and installing it using that.  However, 
> the WFS software doesn't support Windows 98 (only NT, 2k, or XP) so 
> that didn't help too much (although it's the furthest the installer 
> ever got... only to tell me that it wouldn't continue :).
> Since then, I've been trying to get the proper DCOM dll's from a 
> Windows 2000 (server) computer that I have.  I've copied ole32.dll, 
> oleaut32.dll, rpcrt4.dll and comctrl32.dll from my Windoze 2k Server 
> to over to Wine, and used the regsrv32 program to register them.
> (by the way, am I supposed to put them in system or system32?  
> Currently I have them in system32, with symlinks pointing to the 
> system dir....)
> Then I try to run the setup program w/the following command:
> WINEDLLOVERRIDES="ole32,oleaut32,rpcrt4=n" wine 
> /download/watchguard/WFS73s.exe /setup
> But that just gives me the error:
> The InstallShield Engine (iKernel.exe) could not be launched. 
> (0x800768e4)
> I've found similar errors in the Wiki, but not w/that error code that 
> I'm getting.  Does anyone know what 0x800768e4 would mean..?
> I also tried this command (which I found in the wiki):
> WINEDLLOVERRIDES="ole32=n,b;oleaut32=n,b;rpcrt4=n,b" wine 
> /download/watchguard/WFS73s.exe /setup
> but it does the same thing, dies with the same error message... :(
> I'm kinda stumped as to what to try next...
> thx!
> k
> _______________________________________________
> wine-users mailing list
> wine-users at winehq.org
> http://www.winehq.org/mailman/listinfo/wine-users

More information about the wine-users mailing list