[Wine] running application that make use of the com port

Fo Loeng Wahidin flw at zenucom.com
Tue Oct 25 03:13:36 CDT 2005

Dear everybody,

I am a newbie to using wine.

Currently I tried to run an application that try to talk to an opticon 
handhald scanner
connected through a com port.

I have tried using the rpm version (wine-20050524-1fc2winehq.i386.rpm)
as well as compiling wine (2005 09 30 version), and very much get the same

As suggested by the on line documentation, I have created a symbolic link
from the /dev/ttyS0 to $HOME/.wine/dosdevices/com1, and making sure that 
the user running
wine got read and write permission on /dev/ttyS0.

The application starts OK, however when I start the communication,
I got the following message on the console:
*fixme:toolhelp:InterruptRegister16 (0000, 0x11cf00ba), stub.*

and the communication between the application and the scanner connected to
com1 seems to stand still (no comms).

When I terminate the applications, then I get the following message on the
*fixme:toolhelp:InterruptUnRegister16 (0000), stub.
any suggestion?



More information about the wine-users mailing list