[Wine] running application that make use of the com port

Uwe Bonnes bon at elektron.ikp.physik.tu-darmstadt.de
Tue Oct 25 13:34:23 CDT 2005

>>>>> "Fo" == Fo Loeng Wahidin <flw at zenucom.com> writes:

    Fo> Dear everybody, I am a newbie to using wine.

    Fo> Currently I tried to run an application that try to talk to an
    Fo> opticon handhald scanner connected through a com port.

    Fo> I have tried using the rpm version
    Fo> (wine-20050524-1fc2winehq.i386.rpm) as well as compiling wine (2005
    Fo> 09 30 version), and very much get the same behaviour.

    Fo> As suggested by the on line documentation, I have created a symbolic
    Fo> link from the /dev/ttyS0 to $HOME/.wine/dosdevices/com1, and making
    Fo> sure that the user running wine got read and write permission on
    Fo> /dev/ttyS0.

    Fo> The application starts OK, however when I start the communication, I
    Fo> got the following message on the console:
    Fo> *fixme:toolhelp:InterruptRegister16 (0000, 0x11cf00ba), stub.*

    Fo> and the communication between the application and the scanner
    Fo> connected to com1 seems to stand still (no comms).

    Fo> When I terminate the applications, then I get the following message
    Fo> on the console *fixme:toolhelp:InterruptUnRegister16 (0000), stub.
    Fo> * any suggestion?

First run with --debugmsg +relay  and look if the application really opens
COM1. Look for a CreateFile with with appropriate arguments. Then look
further what the application does with the File Handle it got back from

Uwe Bonnes                bon at elektron.ikp.physik.tu-darmstadt.de

Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
--------- Tel. 06151 162516 -------- Fax. 06151 164321 ----------

More information about the wine-users mailing list