[Wine] Persistant prelinking/exec-shield issue - please help. =/

Joey Robinson jsrobinson at gmail.com
Mon Feb 6 03:05:44 CST 2006


I'm experiencing in issue with the latest Wine on Fedora Core 4, latest
kernel and all latest drivers available.

I'm attempting to run World of Warcraft, after compiling a custom build of
wine, with instructions outlined at

Everything compiles fine, and I'm able to run wine to generat the
~/home/user/.wine directory

The problem comes when I try to run the mozilla patcher, I receive an error
that says:

[inferno at localhost ~]$ cd .wine/drive_c/Program\ Files/World\ of\ Warcraft/
[inferno at localhost World of Warcraft]$ wine WoW.exe -opengl
err:virtual:map_image Image was mapped at 0xda0000: standard load address
for a Win32 program (0x00400000) not available
err:virtual:map_image Do you have exec-shield or prelink active?
wine: could not load L"C:\\Program Files\\World of Warcraft\\WoW.exe" as
Win32 binary
[inferno at localhost World of Warcraft]$


I've checked all available settings, and I have fully disabled Prelinking
and Exec-Shield to the best of my knowledge.

I've added b /usr/lib{,64}/wine to /etc/prelink.conf
I've set prelink to no in /sysconfig/prelink and restarted prelink
And I did a set kernel.exec-shield = 0 in sysctl.conf

The issue persists, I've also tried manually installing the Mozilla files
from a different library which worked fine, but I continue to get the error
even when trying to run "wine -WoW.exe -opengl"

Does anyone have any advice? I would be eternally grateful for a direction
to go in. Cedega will not work for WoW for me, as it has a persistant D3D
issue and bad OpenGL support. Wine is my only option. Thank you very much in
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.winehq.org/pipermail/wine-users/attachments/20060206/d9f8f54c/attachment.htm

More information about the wine-users mailing list