[Wine] all apps are black with nvidia driver

L. Rahyen research at science.su
Thu Feb 8 07:38:44 CST 2007

Wednesday February 7 2007 20:44、あなたは書きました:
> This problem occurs with both the open-source nv driver and the
> proprietary nvidia driver. This does NOT happen with the VESA driver, so
> the problem seems to be isolated to the nvidia drivers.

	Personally I have NVIDIA-Linux-x86_64-1.0-9631-pkg2.run installed but I never 
seen your problem with any driver version that I ever used. Therefore your 
conclusion may be true only partially. That is, with your *combination* of a 
driver and a videocard the problem occurs. To check this you should try other 

> nVidia GeForce4 MX440 AGP 64MB

	What can I say... I have GeForce 7600 256MB, GeForce4 Ti 4600 128MB and even 
GeForce2 MX 32MB and no problems.
	You also should keep in mind that when you use old cards, use old driver as 
well. It isn't worth trying to use new drivers with GeForce4. At least in my 
case every 3D apps become much slower in high resolution (and even in low res 
performance isn't very good), and antialiasing doesn't work in high 
resolution at all. Therefore I recommend to use 1.0-8762 (even older ones 
will work better); if you want to use newer drivers it's good idea to buy 
something better, for example I also have GeForce7 256MB and everything works 
perfectly with new drivers.
	But these problems have nothing to do with your problem, of course (that's 
just my personal expirience and recommendations). As I said above, you really 
should try different videocard. For example, any GeForce4 not-MX or higher. 
If problem dissappear then you should upgrade your videocard. If not, then I 
don't know; but I think it is very likely that your problem is because of 
bad/broken videocard (or lack of good support of your card in drivers, this 
doesn't matter from a user point of view).

More information about the wine-users mailing list