[Wine] Civ IV

Joe Auty joe at netmusician.org
Tue Oct 23 02:44:56 CDT 2007

Hash: SHA1

L. Rahyen wrote:
> On Monday October 22 2007 13:39, Joe Auty wrote:
>> L. Rahyen wrote:
>>> On Monday October 22 2007 05:59, Joe Auty wrote:
>>>> I don't have a d3dx9_26 library, only a d3dx9 one. Did I possibly
>>>> install the wrong DLL? Other than this, I have followed these
>>>> instructions. I'm getting the following error:
>>> 	If some DDLs are missing you will see errors about missing DLLs in
>>> terminal output. If you have wrong version of native DLL then you may see
>>> errors about some functions unimplemented in DLL that you installed and
>>> then you need find better version of that DLL. Of course, if you have no
>>> such errors then you don't need additional DLLs.
>>>> Hello,
>>>> I'm trying to get Civ IV running on my 64 bit version of Ubuntu 7.10
>>>> using the latest Wine version using these directions:
>>> 	First try to install your game without any special instructions and
>>> without any DLL overrides. Then try to launch your game like this: cd to
>>> it installation directory and type "wine game.exe". If it fail and say
>>> (in terminal output) that you need some DLLs, install them (just put them
>>> to ~/.wine/drive_c/windows/system32/ directory). If game still doesn't
>>> work then please report bug to http://bugs.winehq.org/ .
>>> 	Reporting bugs is as simple as writing to this list (just make sure
>>> attach long terminal output instead of just pasting it) but most
>>> developers don't read wine-users mailing list at all - they prefer to
>>> read bug reports from http://bugs.winehq.org/ because this is much more
>>> convenient. So if you want to get your bug fixed you really need to
>>> report it at
>>> http://bugs.winehq.org/ .
>>> 	Thank you for using WINE.
>> Thank you!
>> Please find my CivIV output (w. no DLL overrides) attached. The output
>> looks identical, if not similar to my output w. DLL overrides.
>> Could you please identify whether this is indeed a Wine bug, or simply a
>> problem with my install?
> 	Personally, I always try with clean WINE before submitting a bug report. This 
> is very simple:
> rm -rf ~/.clean-wine
> export WINEPREFIX=~/.clean-wine
> wineprefixcreate
> 	Then install your game by running its installer (make sure that you are doing 
> everything in same terminal which have WINEPREFIX pointing to clean wine 
> prefix directory). After doing this try to run it from installation 
> directory. If it still doesn't work then this is bug in WINE. If terminal 
> output is different, output from clean WINE should be proffered.
> 	Please note that your ~/.wine will not be touched - by doing this in a way I 
> described you always be able to test with clean wine prefix directory with 
> very little additional effort and always be sure that the bug you going to 
> report is real bug.
> 	Thanks for using WINE.

I'm a dummy!

Because I didn't see d3dx9_26 in the list of available libraries, like
an idiot I didn't think of typing this in and then clicking "add". After
doing this Civ IV starts up just fine!

My only remaining question relates to how to get Wine apps to play out
of my USB speakers? They are detected under the ALSA driver in winecfg,
I'm just unsure as to how to tell Wine to actually use them?

- --
Joe Auty
NetMusician: web publishing software for musicians
joe at netmusician.org
Version: GnuPG v1.4.6 (Darwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the wine-users mailing list