[Wine] Wine and ALSA problems

Trayax wineforum-user at winehq.org
Wed Dec 10 09:12:45 CST 2008

I run wine 1.0.1-1 under Debian lenny, and sound works only through alsa-oss emulation and wine-oss. When i try to use native ALSA - in winecfg i get "audio test failed" message, and when i try to run any sound-using program (diablo 2, for example), i receive following message:
err:dsalsa:DSDB_CreateMMAP Can't map sound device for direct access: 
file descriptor in bad state
fixme:dsalsa:CheckXRUN Unhandled state: 0
err:ntdll:RtlpWaitForCriticalSection section 0x422661c "../../../dlls/dsound/dso                        und.c: DirectSoundDevice.mixlock" wait timed out in thread 0018, blocked by 001f                        , retrying (60 sec)
err:ntdll:RtlpWaitForCriticalSection section 0x7bc92a44 "../../../dlls/ntdll/loa                        der.c: loader_section" wait timed out in thread 001f, blocked by 0018, retrying                         (60 sec)
err:seh:raise_exception Unhandled exception code c0000194 flags 0 addr 0x7bc3ab6                        0

I have no pulseaudio installed, and i tried to uninstall or kill arts - with no results. Any help/suggestions on what to do?

More information about the wine-users mailing list