[Wine] Re: Simple windows application not quite working

tcherel wineforum-user at winehq.org
Tue Jan 6 13:27:31 CST 2009

> > 
> > Thanks. I found the winetricks Wiki page and I tried what you suggested and quite a few other things as well (installing various native runtimes and DLLs). 
> > Still not luck, text is not being displayed. 
> > I am pinging the author of the program to see if he is using anything particular to display this text (font, UI controls, etc). 
> > 
> This appears to be a problem that is quite common. The solution might be to install the native riched dlls from Windows through the use of Winetricks. Can you try this and report the results?

I did a complete cleanup of my wine installation (uninstall wine, delete the ~/.wine and ~/.winetrickscache) and a clean re-install (to be one the safe side as I tried quite a few things yesterday).
I am using Ubuntu 8.10 and I used the following page to configure the APT repository: http://www.winehq.org/download/deb
I then used the Synaptic package Manager to do the Wine installation.
wine --version returns 1.1.12

I then installed my windows application (http://www.kervenec.net/atoumath/telecharge.php).

I also used winetricks  to install riched20 and riched30. It did not make any differences, the text in my applications is still not displayed.

You can see the screenshot of the working application usign CrossOver here: http://www.placesaintfrancois.fr/wine/ScreenshotCrossOver.png

The same screenshot but using Wine is as follow: http://www.placesaintfrancois.fr/wine/ScreenshotWine.png

As you can see most of the text does not get displayed at all.

More information about the wine-users mailing list