[Wine] Re: City of Heroes control problem. Keys repeat.

ThePenciler wineforum-user at winehq.org
Sat May 2 10:17:09 CDT 2009

tparker wrote:
> ThePenciler wrote:
> > Ah. Ok, I uninstalled SCIM and all the items it wanted to uninstall with it. And I couldn't find anything related to libgxim (so I had nothing to uninstall). I then restarted and it still happens. :(
> > 
> I just tried COH in 1.1.20 (fresh build from source, no patches) to see 
> if I could make mine have the same problem, but no luck, typing and 
> movement both worked as normal.

I have a bad feeling about this now. :(

> Is your wine install a straight source build or did you add any patches 
> in, if so which ones?

No patches. Just WINE.

> Have you played before without having this problem or is this your first 
> try at it through wine?

I've played CoH for at least 2 years with WINE before having this problem.

> If it worked before, have you updated your OS, 
> changed any hardware or input related software between it working and 
> not?

The only thing I've done is upgrade to Ubuntu 9.04 from 8.10.

> Have you used one of the funky keyboards with it's own drivers that 
> might still be on the system and conflicting with something?

Nope, I was using my plain vanilla IBM PS/2 105 key keyboard (model number KB-9910 Rev: E02). Non-multimedia. Looks like the old Mac keyboards, but with the Windows key. I'm now using a ZBoard without any special software. Both keyboards have the same problem with the plain vanilla IBM PS/2 keyboard having the problem first. And I've been using the IBM keyboard (it's NOT a multimedia keyboard) all this time until I started having this problem. Then I attempted to troubleshoot by using the only USB keyboard I have which is my ZBoard WITHOUT trying to find and install any special software to get the multimedia keys to work. REPEAT: I have not installed any software for the ZBoard. It's working as a normal unmodified 105 key keyboard.

> I'm mostly 
> just tossing out ideas to try and find a place for you to start tracking 
> the problem down.

It could be the upgrade from Ubuntu 8.10 to 9.04. If it is the only way I can think of to be sure is to sipe the hard drive and reinstall 9.04 from a CD. If that's the case then I can stand having the problem in CoH since it really doesn't impact performance. Just a little annoying if I forget to tap a second key to get the first key to work right.

More information about the wine-users mailing list