[Wine] ulimit -n ignored/ Max files reached

James Huk huk256 at gmail.com
Fri May 15 08:27:31 CDT 2009

2009/5/15 houkouonchi <wineforum-user at winehq.org>

> Ok, so doing:
> ulimit -n <value>
> then running wine right after that won't work? I also tried putting it in
> my .bashrc which didn't help either.
> I in the past already tried editing /etc/security/limits.conf but it
> doesn't seem to be making a difference. Even if I run env-update any new
> shells or anything like that would just use my old limit of 1024. I never
> had issues like this on rtorrent when I just ran ulimit -n <value> before
> starting it up but I am guessing wine works differently.
> Do you know how I can get the values in /etc/security/limits.conf o take
> affect without rebooting. I can't reboot this machine.
> Thanks for the info!
I don't know why it didn't work for you - In Debian and Ubuntu - it works
just put something like this in /etc/security/limits.conf:
james hard nofile 655355
of course replace james with your username then re-log
BTW - I don't know why but wine does NOT report this as an error - and IMHO
it should - I had to debug Sonic Riders to find out why it was behaving so
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.winehq.org/pipermail/wine-users/attachments/20090515/4b79af63/attachment.htm>

More information about the wine-users mailing list