[Wine] ulimit -n ignored/ Max files reached

Darragh Bailey felix at compsoc.nuigalway.ie
Thu May 21 04:30:46 CDT 2009

On Fri, May 15, 2009 at 02:18:54PM -0500, houkouonchi wrote:
> Ok, well what I don't get is why isn't manually setting it (for that session) working?
> Like open a new terminal then run:
> ulimit -n <newlimit>
> then in that same session:
> wine program.exe
> Why would this not work? This worked fine with rtorrent and other software but doesn't seem to be taking affect for wine?

Did you actually confirm that the ulimit change worked? by default for
users it will remain limited to 1024 unless you edited the limits to
allow a user to increase it. And I wouldn't necessary assume that this
actually changed anything to allow other software to work either. There
could be other reasons.

Before this is labeled as a bug in wine, you need to either
a) Confirm that after running 'ulimit -n <newlimit>' for the same user
that you are starting wine with has actually worked
b) Increase limits correctly for your user

Run the following just before starting wine:
# ulimit -Hn

P.S. Sorry about taking so long to respond.

"Nothing is foolproof to a sufficiently talented fool."

More information about the wine-users mailing list