[Wine] Re: DirectX troubles - Running Civilisation IV: Beyond the Sword

dimesio wineforum-user at winehq.org
Wed Jul 14 15:19:10 CDT 2010

WarKirby wrote:
> I have done a new wineprefix as stated. Winetricks worked correctly, and I installed d3dx9_26 and msxml3. 
> Civilisation still will not start, though. So I next tried installing:
> d3dx9
> d3dx9_28
> directx9
> msxml4
> Still, not working. The error message is the same as it ever was, about failing to initialise the renderer.
> I installed Civ4 on a different drive, not within the wine directory. So I did not reinstall it. Does this seem a necessary thing to do? I have no issues running Poser 7 and various other wine apps from additional drives.
> The appdb does not appear too helpful: http://appdb.winehq.org/objectManager.php?sClass=version&iId=16878
> I await farther instruction. Any other ideas?

Run it from a terminal and post the terminal output, including the command you use to start it. http://wiki.winehq.org/FAQ#run_from_terminal

More information about the wine-users mailing list