[Wine] World of Warcraft - IBM T400 Intel Graphics, FC13 - opengl

Atonner_osh wineforum-user at winehq.org
Sat Nov 27 12:27:10 CST 2010

Greeting folks -- 

   1) I have wow running fine in recent wine on a Gentoo system with Nvidia graphics card
   2) No, I have never successfully gotten wow running in opengl on the lenovo (ibm) t400 
  I'm just trying to get it running:
  Lenovo is running FC13, with much stuff from updates-testing - the Lenovo is using the Intel GM945 chipset for video.

I can get the game running in d3d mode with wine from updates-testing (or compiled from source from sourceforge.com) - with playable frame rates, but my preference, and stubborness, require that I get opengl mode working.

   When starting (either launcher/wow) with opengl (and or SET gxApi opengl) I have a failure immediately after getting zoned into the game (time frame is usually 5 or 6 seconds of runtime)

   The abort clearly comes from this section (from WINEDEBUG=+opengl)

e:opengl:wine_glBindProgramARB (34820, 87)                                                                                                                                            
trace:opengl:wine_glBindTexture (3553, 512)                                                                                                                                               
trace:opengl:wine_glEnable (2896)                                                                                                                                                         
trace:opengl:wine_glLightModelfv (2899, 0x33fb0c)                                                                                                                                         
trace:opengl:wine_glViewport (0, 0, 1440, 900)                                                                                                                                            
trace:opengl:wine_glDepthRange (0.000000, 1.000000)                                                                                                                                       
trace:opengl:wine_glVertexAttribPointerARB (0, 3, 5126, 1, 24, 0xc942020)                                                                                                                 
trace:opengl:wine_glVertexAttribPointerARB (4, 4, 5121, 1, 24, 0xc94202c)                                                                                                                 
trace:opengl:wine_glVertexAttribPointerARB (6, 2, 5126, 1, 24, 0xc942030)                                                                                                                 
trace:opengl:wine_glDrawRangeElementsEXT (4, 0, 3, 6, 5123, 0xa1100f0)                                                                                                                    
trace:opengl:wine_glMatrixMode (5889)                                                                                                                                                     
trace:opengl:wine_glLoadMatrixf (0x33fc14)                                                                                                                                                
trace:opengl:wine_glLoadMatrixf (0x33fa88)                                                                                                                                                
trace:opengl:wine_glLoadMatrixf (0x33faf0)                                                                                                                                                
trace:opengl:wglSwapLayerBuffers (0x764, 00000001)                                                                                                                                        
trace:opengl:wine_glLoadMatrixf (0x33f7b4)                                                                                                                                                
trace:opengl:wine_glLoadMatrixf (0x33f804)                                                                                                                                                
trace:opengl:wine_glGenTextures (1, 0x53c8dab8)                                                                                                                                           
trace:opengl:wine_glBindTexture (3553, 3464)                                                                                                                                              
trace:opengl:wine_glTexParameteri (3553, 10240, 9729)                                                                                                                                     
trace:opengl:wine_glTexParameteri (3553, 10241, 9987)                                                                                                                                     
trace:opengl:wine_glTexParameteri (3553, 10242, 33071)                                                                                                                                    
trace:opengl:wine_glTexParameteri (3553, 10243, 33071)                                                                                                                                    
trace:opengl:wine_glTexParameteri (3553, 34046, 2)                                                                                                                                        
trace:opengl:wine_glTexParameteri (3553, 33085, 8)                                                                                                                                        
trace:opengl:wine_glPixelStorei (3314, 0)                                                                                                                                                 
wine: Unhandled page fault on execute access to 0x00000000 at address (nil) (thread 004c), starting debugger...                                                                           
fixme:process:GetLogicalProcessorInformation (0x198e380,0x198e980): stub                                                                                                                  
fixme:process:GetLogicalProcessorInformation (0x198e380,0x198e980): stub                                                                                                                  
Unhandled exception: page fault on execute access to 0x00000000 in 32-bit code (0x00000000). 

   Can anyone make a suggestion as to a) my next steps for debugging and b) what/where I should go next?
   (the error above is the exit point with -opengl for both the wine (1.3.7 from updates testing or 1.3.8 from source code)  and **apparently** is an identical error on both code bases, and all 10 characters I have on wow.

  I've pushed the edge on Xorg, and video drivers on this machine ---- any other hints/suggestions would be greatly appreciated (and  possibly will make this machine raid capable, which it most definitely is not in d3d mode.

More information about the wine-users mailing list