[Wine] No sound, no information why, where to start?

jordan triplesquarednine at gmail.com
Tue Sep 14 22:04:40 CDT 2010

On Tue, Sep 14, 2010 at 3:03 AM, atle <wineforum-user at winehq.org> wrote:
>>Ya, I don't use KDE, i just naturally assume it plays a similar role
> to Pulseaudio (which also can set sound).
> Sorry, bad description on my part. kmix is an alsamixer equivalent for KDE. It doesn't play anything, or mix sound streams like dmix.

That makes sense...

>>That's kind of what i would expect to see.
> I wouldn't. Where is gstreamer finding a default ALSA device that aplay can't find?

I never have had to use aplay, in my life...and ironically, I use
linux mostly for proaudio.  And it does make sense to me, as that is
how alsamixer would show them, and that is how
Jack-audio-connection-kit would display them.
KDE, aplay, that's a whole other ball game. I have no idea whay that
would be different.

> This is linked to the previous question, why can't aplay -L or KDE4/phonon/gstreamer find the devices I create in asound.conf?
> I wish there would be some more consistency here.

The one and only time that i needed to create a device in asound.conf,
it worked just fine. but again, i am using a much different setup than

>>Have you tried a fresh install of Wine??? you can do this simply by
> renaming your .wine folder (as to not lose anything), then try
> uninstalling Wine.
> I'll try that. I have only tried removing .wine to recreate settings.
>>For you to not have changed anything, and
> it just stopped working.
> I didn't say that. I upgrade gentoo all the time. I even upgrade kernel now and then. Also I've changed from a ATI47** to an ATI56**. But these are steps that cannot easily be reversed.

Obviously not..... If your ATI56 has an audio device, maybe that was
the cause.  Is that the point in which your problems began?   Upgrades
can break things, but not likely when portage is configured correctly.
a new kernel wouldn't do that either, as no sound would work at all.
I install a new kernel, just about every week.
I use Zen-kernel with gentoo on one machine, and Zen + Fedora 13 on my
pro-audio machine.

> Also, sound is working. It's just wine doing something strange. But I'll try reinstalling it tonight.
> What I miss is something like what was used in the old ~/.wine/config:
> [ALSA]
> "PlaybackDevice" = "default"
> (Ref: http://wiki.jswindle.com/index.php/Wine_Config_File)
> If I found a way to do the same in the new .reg files, I'd be happy.


Definetly have a look through there.  I mess with the registry all the
time, and feel quite comfortable doing it.
I even modify specific application registry keys, with they have keys
that potentially are worth modifying.
I've been able to get a few apps to work better doing this.


More information about the wine-users mailing list