[Wine] Civilization IV installation on ArchLinux 64bit fails

celdrion wineforum-user at winehq.org
Mon Sep 20 13:51:39 CDT 2010

Hello everyone.

I tried to install Civ4 version 1.61 on my ArchLinux 64bit system with wine 1.3.3. Unfortunately the installation fails. I get to the point when I get asked to choose the language and then the installation fails giving me a lot of error messagess like these in the terminal:

fixme:heap:HeapSetInformation 0x7f830746b000 0 0x7f830c5bfcb0 4
fixme:atl:AtlModuleInit SEMI-STUB (0x40f900 0x40f010 0x400000)
err:ole:marshal_object couldn't get IPSFactory buffer for interface {7871bfad-dad5-402f-9007-2593e9a07532}
err:ole:ClientIdentity_QueryMultipleInterfaces IRemUnknown_RemQueryInterface failed with error 0x80004002
err:ole:StdMarshalImpl_ReleaseMarshalData could not map object ID to stub manager, oxid=3c00000030, oid=2
err:ole:CoReleaseMarshalData IMarshal::ReleaseMarshalData failed with error 0x8001011d

Afterwards I installed msxml4, d3dx9 and vcrun2003 as suggestede in the AppDB, but still the same. Then I tried to do it as suggested here http://appdb.winehq.org/objectManager.php?sClass=version&iId=5254&iTestingId=49228 although it is not the same version of Civ4. With this route I get the same messages.
Does anybody know what to do to get it to run?

More information about the wine-users mailing list