[Wine] Impulse fails to start

tylerbraun wineforum-user at winehq.org
Wed Aug 3 10:12:30 CDT 2011

So I tried to run Impulse on my Ubuntu 11.04 laptop and it installed fine (or at least seemed to). When I tried to run it I got the working cursor for a bit then nothing. I ran it in terminal and got a error message about running the Windows version of Mono so I went online and did a search for the error message and found a file called mono- and ran it. The error message went away, but Impulse still won't load so I ran winedbg Impulse.exe instead and got this:

WineDbg starting on pid 0019
First chance exception: page fault on write access to 0x00360000 in 32-bit code (0x685bf54b).
Register dump:
 CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b
 EIP:685bf54b ESP:0033f820 EBP:0033f898 EFLAGS:00010a02(  R- --O I   - - - )
 EAX:80808081 EBX:6865fff4 ECX:00000000 EDX:00000067
 ESI:000000ac EDI:00360000
Stack dump:
0x0033f820:  0000031c 00000000 00000000 00000010
0x0033f830:  00000010 00000000 00000000 00000010
0x0033f840:  00000010 68471d9c 00134788 00000000
0x0033f850:  00cc0020 00000000 00330001 6c4e0001
0x0033f860:  0033f878 0000031c 00134ff8 00000328
0x0033f870:  00000000 00000000 00000010 00000010
=>0 0x685bf54b in user32 (+0x1f54b) (0x0033f898)
  1 0x685bfd38 in user32 (+0x1fd37) (0x0033f918)
  2 0x685bfe8c in user32 (+0x1fe8b) (0x0033f968)
  3 0x685c0298 CreateIconFromResourceEx+0xd7() in user32 (0x0033f9b8)
  4 0x685c06a3 in user32 (+0x206a2) (0x0033fa88)
  5 0x685c2948 LoadImageW+0x1b7() in user32 (0x0033fb98)
  6 0x685c3476 LoadImageA+0x1a5() in user32 (0x0033fc88)
  7 0x683895c6 SIC_Initialize+0x1b5() in shell32 (0x0033fcd8)
  8 0x68395602 in shell32 (+0x35601) (0x0033fd18)
  9 0x7bc49275 call_dll_entry_point+0x14() in ntdll (0x0033fd38)
  10 0x7bc4bee7 in ntdll (+0x3bee6) (0x0033fe78)
  11 0x7bc4c298 in ntdll (+0x3c297) (0x0033fed8)
  12 0x7bc4c26a in ntdll (+0x3c269) (0x0033ff38)
  13 0x7bc4c26a in ntdll (+0x3c269) (0x0033ff98)
  14 0x7bc4c4a3 in ntdll (+0x3c4a2) (0x0033ffe8)
0x685bf54b: movb	%dl,0x0(%edi,%ecx,4)

I was also told just now that I should be running the command "mono Impulse.exe" instead of "wine Impulse.exe" but that didn't work either. I just got this:

** (Impulse.exe:6763): WARNING **: The following assembly referenced from /home/tyler/.wine/drive_c/Program Files/Impulse/Impulse.exe could not be loaded:
     Assembly:   System.Windows.Forms    (assemblyref_index=1)
     Public Key: b77a5c561934e089
The assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/home/tyler/.wine/drive_c/Program Files/Impulse/).

** (Impulse.exe:6763): WARNING **: Could not load file or assembly 'System.Windows.Forms, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies.

Unhandled Exception: System.TypeLoadException: Could not load type 'Stardock.Central.Client.Program' from assembly 'Impulse, Version=3.30.4164.19374, Culture=neutral, PublicKeyToken=null'.

I'm not experienced or trained enough to read either of those. Does anybody know what they mean and/or how to fix it?

More information about the wine-users mailing list