[Wine] Odd window behaviour

David Shaw dj.shaw at btconnect.com
Sun Aug 21 10:22:57 CDT 2011

I have a short script (below) which I use to launch my program (Campaign 
Cartographer 3).  If I run this from the terminal, I have no problems 
but if I attach it to a launcher on the panel then as soon as I move the 
mouse into the window, it closes down without any error popping up - but 
*only* if the program runs in a maximised window; if I start the program 
in a smaller than maximised window, it works fine, even if I then switch 
to maximised.

Obviously, running it from a launcher means that I have no terminal 
output to give me any leads, so I'm hoping someone can shed some light 
on this peculiar behaviour.

Many thanks,

David Shaw

OS		Ubuntu 10.04
Wine version	1.3.26
lspci output	VGA compatible controller: nVidia Corporation C67
		[GeForce 7000M / nForce 610M] (rev a2)
		Subsystem: Hewlett-Packard Company Device 30ea
		Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 16
		Memory at f5000000 (32-bit, non-prefetchable) [size=16M]
		Memory at d0000000 (64-bit, prefetchable) [size=256M]
		Memory at f4000000 (64-bit, non-prefetchable) [size=16M]
		[virtual] Expansion ROM at 80000000 [disabled]
		Capabilities: <access denied>
		Kernel driver in use: nvidia
		Kernel modules: nvidia-current, nvidia-173, nvidiafb,

========== Script Starts ==========

export WINEPREFIX='/home/david/.wine-prefix/CC3'

cd $WINEPREFIX/drive_c/Program\ Files/ProFantasy/CC3

wine fcw32.exe
=========== Script Ends ===========

More information about the wine-users mailing list