[Wine] Direct rendering disabled on intel i965 (Morrowind&Debian)

F.E. wineforum-user at winehq.org
Fri Jul 22 09:13:00 CDT 2011


I am running Debian wheezy on my ThinkPad laptop. My architecture is amd64, the graphics card is an Intel i965 and I am using wine 1.3.24 from http://dev.carbon-project.org/debian/wine-unstable

My problem is that Morrowind runs really slow, around 5-10 FPS, completely unplayable.

I tried setting LIBGL_DRIVERS_PATH=/usr/lib32/dri but that didn't make a difference. Running it with/without desktop effects didn't work either. I even tried running the game on its own X server with xinit!

The problem is that direct rendering is not enabled on Wine (it is enabled for native apps. though).

Check out the following debug info:

libGL: OpenDriver: trying /usr/lib32/dri/tls/i965_dri.so
Unrecognized deviceID 126
trace:wgl:X11DRV_WineGL_InitOpenglInfo GL version : 1.4 (2.1 Mesa 7.10.3).
trace:wgl:X11DRV_WineGL_InitOpenglInfo GL renderer : Mesa DRI Intel(R) Sandybridge Mobile .
trace:wgl:X11DRV_WineGL_InitOpenglInfo GLX version : 1.4.
trace:wgl:X11DRV_WineGL_InitOpenglInfo Server GLX version : 1.4.
trace:wgl:X11DRV_WineGL_InitOpenglInfo Server GLX vendor: : SGI.
trace:wgl:X11DRV_WineGL_InitOpenglInfo Client GLX version : 1.4.
trace:wgl:X11DRV_WineGL_InitOpenglInfo Client GLX vendor: : Mesa Project and SGI.
trace:wgl:X11DRV_WineGL_InitOpenglInfo Direct rendering enabled: False
err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly

Can anybody help me, please?

More information about the wine-users mailing list