[Wine] Help compiling an older version of wine on 64 bit Fedora 14

Giles wineforum-user at winehq.org
Tue Mar 1 10:16:53 CST 2011

I'm having problems running a windows program (nulldc 1.0.3 but that's not important) under the latest version of wine, which is up and running (in 32 bit) on my 64-bit install of Fedora 14. I'm trying to compile a version of wine 1.1.32 under a separate prefix. I'm doing this in a way that has worked for me in the past under a 32-bit environment. As I say, I've compiled the latest version of wine and it's behaving well; my problem is getting an older version up and running under a separate prefix.

I've got all the 32 bit dependencies installed as per the building wine on fedora 14 section of the wine wiki: http://wiki.winehq.org/WineOn64bit
I downloaded wine 1.1.32 from source.

First of all I used the following method to build and install wine 1.1.32 from source, as recommended by the wiki:


$ ./configure --prefix "/home/mythtv/.nulldcwine" && make &&  make install
$ cd ~/.nulldcwine/bin
$ WINEPREFIX="/home/mythtv/.nulldcwine" ~/.nulldcwine/bin/winecfg

however, on executing the local version of winecfg, I get a segfault:


Segmentation fault (core dumped)

In semi-desperation I tried manually creating a prefix with wineprefixcreate, but this also gave me a segfault


$ sh wineprefixcreate --prefix /home/mythtv/.nulldcwine
Note: wineprefixcreate is deprecated and shouldn't be needed anymore.
      WINEPREFIX creation and updates now happen automatically when needed.

wineprefixcreate: line 134: 31497 Segmentation fault      (core dumped) "${WINELOADER:-$bindir/wine}" wineboot.exe

Going back to the drawing board I used a different build method, that had worked in the past in a 32-bit environment:


$ CFLAGS=-fno-stack-protector ./configure --prefix="/home/mythtv/.nulldcwine" && make depend && make && make install

but on running a prefixed version of winecfg, I get a segfault again.
Needless to say, I get a segfault when trying to run a program with wine as well with both build methods:


$ WINEPREFIX="/home/mythtv/.nulldcwine" ~/.nulldcwine/bin/wine ~/.nulldcwine/drive_c/"Program Files"/nulldc103/nullDC_1.0.3_nommu.exe
Segmentation fault (core dumped)

This method has worked flawlessly for me in the past in  32-bit Fedora - What am I doing wrong in 64-bit?

More information about the wine-users mailing list