[Wine] COPILOT Glucose Meter COM problem

williambuell wineforum-user at winehq.org
Fri Nov 11 12:42:28 CST 2011

I am a 62 year old beginner in Ubuntu. Thanks for any help, guidance, suggestions on this problem!

I have used commands like the following to be certain that I have an active com port: 
dmesg | grep ttyS
rm com1
ln -s /dev/ttyS0 com1

So I suspect the solution lies somewhere in WINE.

If all else fails I will get a USB to SERIAL converter cable and try that.

My wife has an Abbott Labs Freestyle Lite Glucose meter which uploads to a program called COPILOT via RS232. I was only able to get it to work on ONE of our three Windows XP machines. I tried all day to get it to work on a Dell XP converted to Ubuntu (Gnu/Linux) which d...oes have an RS232 and TERMINAL commands indicate that the system recognizes that COM port. I am running COPILOT with WINE (which lets Windows programs run under Ubuntu).

I have yet to master the secrets of Wine REGEDIT:

WINE Regedit

If I navigate to .wine and then to drive_c and then to windows I can issued the REGEDIT command and edit the wine registry and navigate to the HKEY_LOCAL_MACHINE -> HARDWARE -> DESCRIPTION -> SERIALCOMM

I have tried to add "COM1"="COM1" to that SERIALCOMM, and the add shows but then it disappears the next time I run REGEDIT.

I found THIS excerpt which seems pertinent:


I have COM1 on wine apps. I symlinked ttyS0 and added these keys


But regedit deletes them.

If I do this

wine regedit serial.reg
wine regedit

I see the keys.
I open my program with regedit opened and I see com1 and com2

But If I close regedit, then keys disappears...

The EXPERT explains: It's not regedit, they are never saved.

[HKLM\HARDWARE] is a volatile registry branch - it exists in memory only and is not being saved to disk.

Just add it to ~/.wine/system.reg. Be careful editing that file, if you break it whole registry can get corrupt.



Usually with a com port it is a permissions issue. Some programs need further fixes in wine, but often if you cannot see it, it is a permissions issue. Previously you needed to add a link to the port under dos devices, but more recently it seems to auto detect ports. If desperate check that your bios has the serial port enabled, and try loging as a super user and changing the permissions to read and write for anyone on all of the serial ports (it usually reverts when you reboot):
chmod 775 /dev/ttyS*
If this fixes your problem then you know it is a permission issue and then can research how set it up with a more delicate touch.

In wine's system.reg way at the bottom of the file I find:

[System\\CurrentControlSet\\Control\\Class\\ .... lots of numbers
@="Ports (Com & Lpt)"

AND I SUSPECT that if I add something here e.g. "COM1"="COM1"
then possibly my application might work and read the com port

BUT I am not certain exactly what to add.

This may be another place to add COM1 lines





I am saving COPIES of each file that I tamper with in case it becomes corrupted.

Today I will walk up the street to J&R Computers and purchase a USB to Serial converter cable and give that a try.

The glucose meter is Abbot Labs FreeStyle Lite
The program in question is
1: AbbottHandler.HA Ver:

Importer Version:

Product name:
Version: US
Internal version: <info not available>.<info not available>.<info no

More information about the wine-users mailing list