[Wine] Re: Ubuntu 12.04 64bit, Wine 1.5.3, OpenGL issue

make_lib wineforum-user at winehq.org
Tue May 8 09:01:15 CDT 2012

I'd like to add my woes to this list.

I'm running 64 bit Debian. I compiled 1.5.3 a few days ago to try steam.

I get the same errors which OP talks about i.e. wine spams the error:

err:wgl:is_extension_supported No OpenGL extensions found, check if your OpenGL setup is correct!

I haven't tried any d3d games due to lack of time, but when I try Borderlands for instance, the splash logo is displayed, then a fraction of a second of sound, then blackness. I can kill Borderlands.exe by logging in via ssh. After killing, I discover the same OpenGL message spammed continuously until I killed the game.

I noticed the common solution to this problem was that the /usr/lib32/libGL.so must've been missing.

However I compiled my own fglrx drivers and found the link /usr/lib32/libGL.so.1.2 to /usr/lib32/fglrx/fglrx-libGL.so.1.2 and issuing the command file on this gives:

matthew at mitboom:/usr/lib32/fglrx$ file ./fglrx-libGL.so.1.2 
./fglrx-libGL.so.1.2: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped

So I definitely have a 32-bit version of libGL.

Which means that wine must really be broken here.

Maybe I didn't read the bug reports correctly, but it seems like this isn't something that can be easily solved.

More information about the wine-users mailing list