[Wine] DirectSoft 5 Serial communications Issue's

Martin Gregorie martin at gregorie.org
Mon May 21 17:45:39 CDT 2012

On Mon, 2012-05-21 at 16:33 -0500, samuraimarc wrote:
> I have not tried this, with out the symlink what do I tell it to
> connect to with no com*
My system finds all my serial ports without using symlinks. My one
serial port Windows app, which downloads logs from a flight recorder,
shows a menu of all the ports it finds and allows me to select the one I
have the flight recorder connected to.

I should add that /dev/ttyS0 (which appears as COM1) is on the mother
boarfd and the other four, /dev/ttyS[1234] (which appear as COM2 to
COM5) are on a multi-port adapter card and all five of them are reported
by setserial as 16550A UARTS. I also have a pFranc USB serial adapter
which has never worked with Wine, regardless of permissions or use of
the symlink. I have never owned or tried a PCMCIA serial card. 

BTW, don't forget that the device files (/dev/ttyS[01]) will be
destroyed when the PCMCIA card is removed and recreated when its plugged
in, so you probably need to use UDEV local rules to give it the
appropriate access permissions. That's likely to be much easier to
manage than scripting it, which will require you to use sudo and to
supply your password. See here for details:

> > ln -s /dev/ttyS0 ~/.wine/dosdevices/COM1:
> I've tried all sorts of COM* com* with no effect, or are you talking
> about the colon on the end?


More information about the wine-users mailing list