[Wine] Running Unity3D Editor with Wine

Cauê Waneck waneck at gmail.com
Wed Nov 13 02:59:53 CST 2013

Okay, I got some progress.

It's definitely related to timezone (see first
error, fixme:ntdll:find_reg_tz_info Can't find matching timezone
information in the registry for bias 180, std (d/m/y): 17/02/2013, dlt
(d/m/y): 20/10/2013 ). When I change my system timezone to London, it works

Any ideas on how to fix it? Thanks!

2013/11/13 Cauê Waneck <waneck at gmail.com>

> Hello!
> I'm new to wine development - it pretty much has worked out of the box
> with everything I needed. :)
> I've been looking however to improve my current development workflow when
> working with Unity 3D (can be downloaded for free at
> http://www.unity3d.com ). I've tried using it with Wine a couple of times
> - to no avail. My current workflow involves then running a virtual machine
> (and all the pains that come from this).
> There are some success reports at WineHQ (link:
> http://appdb.winehq.org/objectManager.php?sClass=version&iId=28175 ),
> which seems to hint to me that it may be a 3D driver-related issue. And
> yes. I've tried to follow this (and many other) installation steps.
> I've tried many different Wine versions - namely 1.4.1, 1.5.10, 1.7.6,
> 1.7.0, 1.6. I tried the first two on both 32-bit and 64-bit environments,
> and the rest only on 32-bit.
> The result is always the same - the program starts, but I get a blank
> window (picture available at http://i.imgur.com/UA6Q3rH.jpg ).
> I've upped some of the debug traces at
> https://gist.github.com/waneck/29f02bbc685d93a79f58 . By far, the most
> helpful one is the log from 1.4.1, which is the only one that shows an
> actual error message: err:wgl:internal_SetPixelFormat Couldn't set format
> of the window, returning failure
> I'm a little at loss on how to proceed here. I'd like to debug this
> further, and if possible, help to solve the issue. However I don't even
> know where the issue might be. Any help to guide me to solving this will be
> very much appreciated!
> I'm using a GeForce GTX 650 Ti with NVIDIA-Linux-x86_64-310.44 proprietary
> drivers. I've tried replacing compiz with metacity - also without any
> change in behaviour.
> My system details:
> ~ $ uname -a Linux xxxx 3.5.0-41-generic #64-Ubuntu SMP Wed Sep 11
> 15:36:42 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
> ~ $ lsb_release -a LSB Version:
> core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
> Distributor ID: Ubuntu Description: Ubuntu 12.10 Release: 12.10 Codename:
> quantal ~ $ cat /etc/issue Ubuntu 12.10 \n \l
> Thanks for any help!
>  Cauê
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.winehq.org/pipermail/wine-users/attachments/20131113/b2600132/attachment.html>

More information about the wine-users mailing list