recording sound?

Thomas Flynn flynnt at
Sat Feb 10 02:20:45 CST 2001

On Wed, 7 Feb 2001, James Hatheway wrote:

> Create a file in there called system.ini, and you need at least the following
> two lines:
> [mci]
> waveaudio=mciwave.drv
> You can see a sample in CVSROOT/documentation/samples/system.ini

I think we're on the right track...

I tried with just the two lines you mentioned as my system.ini, and the
app starts and then hangs.   These are the messages at the bottom:

trace:mmsys:mciSendCommandA (00000001, MCI_GETDEVCAPS, 00000102, 4054637c)
trace:mciwave:MCIWAVE_DriverProc (00000001, 40357F30, 0000080B, 00000102, 4054637C)
trace:mmsys:mciGetDriverData (0001)
trace:mciwave:WAVE_mciGetDevCaps (1, 00000102, 0x4054637c);
trace:mmsys:mciSendCommandA => 00000000
trace:mmsys:mciSendCommandA (00000001, MCI_STATUS, 00000102, 40546374)
trace:mciwave:MCIWAVE_DriverProc (00000001, 40357F30, 00000814, 00000102, 40546374)
trace:mmsys:mciGetDriverData (0001)
trace:mciwave:WAVE_mciStatus (1, 00000102, 0x40546374);
err:ntdll:RtlpWaitForCriticalSection Critical section 0x400f320c wait timed out, retrying (60 sec) fs=0247

I also tried the system.ini from documentation/samples/.  Same messages.
Although I no longer get any messages about MCI_LoadDriver failing to load.
Any ideas what else I could be missing? 

"Mongooses are famous for their snake-fighting ability, and are
 almost always victorious because of their speed, agility, and timing
 and also because of their thick coat."

More information about the wine-devel mailing list