the dreaded rpcss patch (rpc_J_PL0)

Greg Turner gmturner007 at
Mon Nov 18 21:18:22 CST 2002

On Monday 18 November 2002 05:48 pm, Alexandre Julliard wrote:
> A few things:
> - Please don't name files 'kludge_something'; this makes it
> impossible to implement things properly without renaming files.

ok.  since it's a possibility to keep the named pipes kludge for local 
RPCs even once we do have a proper implementation, this is an 
especially sensible request.

> - Don't share C files between rpcrt4 and rpcss, just copy the stuff
>   you need 

hmm... for the named pipe client-side functionality this seems like it 
would create an awfully large amount of code duplication... can I 
export these from a dll somewhere?  or could I just put them in 
rpcss_shared.h?  the prospect of keeping two identical units in sync 
seems awkward.

> (and at least atomicity.c doesn't seem necessary at all,
> you could just as well make mutex calls directly).

I guess you are right, not sure why I did it that way...

> - Please get rid of the various #ifdefs.
> - It would be better to put the README documentation directly in
>   rpcss_main.c, people don't notice README files in subdirectories.

10-4.  Let me know if you have any suggestions about the code 
duplication thing and I'll fix these things up and resubmit.


"War is an ugly thing, but not the ugliest of things;
the decayed and degraded state of moral and patriotic
feeling which thinks that nothing is worth war is much
worse. A man who has nothing for which he is willing
to fight; nothing he cares about more than his own
personal safety; is a miserable creature who has no
chance of being free, unless made and kept so by the
exertions of better persons than himself."

-- John Stuart Mill

More information about the wine-devel mailing list