My adventures with Wine and Netscape

Darrin Edwards edwards at
Wed Aug 22 15:06:38 CDT 2001

I recently installed wine-20010731, and for the past week or so
I was trying unsuccessfully to get a version of Netscape (various
4.0+'s, for various win versions) to install; I needed a particular
3rd party plugin only available in .exe format.  I found on google
a reference from about a year ago of someone getting this to work,
so I was going to post today with questions; lo and behold, last
night I finally got NN 4.61 to install (and run even, and download
pages no less! :)), so I thought instead I might post my experiences
in case they might be of interest or at least solicit comment.  My
apologies if this is all old news, I am very new to wine.

I had been trying various NN versions from 4.06 through 4.78, for
win31, 95, 98, and 2000; the install .exes would always hang at
a particular point (a message box saying "Verifying path" or some
such).  Last night (trying 4.61 for win98) I finally paid closer attention
to what was happening before that; the install was scheduled for
a directory that didn't actually exist.  That hadn't clicked, because
the parent directory was owned by me, and in any case world-writable;
then I realized maybe it wasn't wine having any trouble, but a windows
thing, so I manually created the directory.  The install went through!
At least to the 96% mark, hanging on "Creating icons"; but from my
google explorations I remembered a suggestion that sometimes one could
abort these things late in the install stage without missing much.  This
in fact worked in my case; whatever I was missing, I was able to fire
up netscape.exe in wine and actually access (remote) pages.  (It is
a tribute to the wine developers that I know nothing about windows
networking, and little about unix networking, but didn't have to; I
guess wine is transparently handling the interface between netscape's
requests and my ppp connection, but I didn't need to do _anything_
to configure this; how does it know it's ppp and not something else???
Maybe ignorance on my part but it seems cool to me...)

Only two issues, more curiousities than problems I would say.  When
netscape is now fired up, I always get a dialog box warning me that
E: is missing; this is odd because the directory wine is treating as
E: (/usr/local/e/) is still there, still should be readable, and indeed
still contains all of netscape's install spoor. ;)  But as nothing
currently seems to need this (tmp?) drive (I haven't tried installing
independent programs since), I am not going to worry about it.

Second is the plugin I mentioned, the reason I needed to install
netscape.exe in the first place.  It (the plugin) actually seemed to
install itself, but cannot be currently _used_; netscape claims
(another dialog box) the plugin's .ini file is inaccessible due to a
"permissions" problem (I am using --winver win98, and thought that
it didn't use administrator vs. user permissions?).  All the directories
in the path are world readable, most are world writable, as is the
.ini itself; but I noticed the file is 0 bytes in size.  I do _not_
think this is a wine-related problem, but I hoped folks here might be
likely to know (I am fairly unfamiliar with MS Windows, last I used
was 3.11): is this a possible/typical scenario, a 0-byte file giving
(bogus) permissions errors?  Anyway I sent a help request to the
plugin providors for a "new" .ini file, we'll see what they say. :)

In conclusion, my experiences so far with wine (I've got a funnier
one prior to the netscape if anyone is interested :)) have been
neither uninteresting nor unsatisfying, and I am really grateful to
the developers for the tremendous amount of effort that has gone into
this project.


More information about the wine-users mailing list