ExitThread won't.

Ove Kaaven ovehk at ping.uio.no
Thu Mar 21 21:42:00 CST 2002

On 21 Mar 2002, Geoffrey Hausheer wrote:

> Okay, so with complete lack of any other ideas, I tried to 
> figure out what was wrong with my app (Proxomitron), which
> is leaving unkillable processes around.
> So I went into ExitThread, and added something like:
>     DPRINTF("%08lx:Exiting thread...(%d)\n", GetCurrentThreadId(),getpid());
>     exit(code);
> right at the top of the function.
> And, lo and behold, the processId matches the processes 
> that 'ps' can't kill. So the 'exit' isn't actually 
> terminating the process.  How is that possible?
> This was all done against today's CVS.
> I don't know which messages in the trace might indicate
> what is going wrong.  Does anyone have any ideas?

Hmm. Does the wineserver ever ptrace-attach to the thread?
(maybe try --debugmsg +server)

Have you tried to kill the processes with -CONT to see if that helps them
go away after you've tried the other termination signals?

More information about the wine-users mailing list