[Wine]Re: _wrapped_ java application with wine

Aneurin Price wine at shadovald.dyndns.org
Sat Oct 30 07:28:50 CDT 2004

Mario Ohnewald wrote:
>>Your question was already answered in the reply to your first post.  
>>>This means that if you want to run a Java-programm, 
>>>you have to install Java.
>>He didn't mean that you have to install the jre with wine.  He meant
>>that you should go to java.sun.com, click on the J2SE 5.0 link, and
>>download the binary that is compatible with your system.  It looks
>>like you're running debian, so you can download the linux jre and
>>install it.  Wine isn't needed for java.
> I know! Java is Plattform or OS independent.
> But fact is that you can not run this application with java only, you need
> to  start it with wine.
> Please proof me wrong:
> http://www.3dgamers.com/dlselect/games/il2sturmovik2/il2fb_server1.11.exe.html
> I hope i am wrong. But i have already tried so much, and asked many ppl,
> that i think wine is the only solution :(
> If you have 5mins, download that application, and try to run it with java.
> It never worked for me. :(
> Thanks, Mario

5 minutes for several hundred MBs seem a *little* optimistic :), but I 
tried it. It didn't want to install, giving the error:
     $ wine il2fb_server1.11.exe
     err:virtual:map_image Image was mapped at 0x40750000: standard load
     address for a Win32 program (0x00400000) not available
     err:virtual:map_image Do you have exec-shield or prelink active?
     wine: could not load L"Y:\\Desktop\\il2fb_server1.11.exe" as Win32

I don't have exec-shield or prelink active, and not being bothered to 
figure out what was going on I just unzipped it. This seemed to work fine.

 From there, I didn't get the error you got:
     $ wine il2server.exe
     IL2 FB dedicated server v1.11

But then nothing happens (ie. the program closes without producing a 

     $ wine il2sconsole.exe
     Couldn't get I/O for the connection to IL2
Same thing.

     $ wine il2wconsole.exe
     Exception in thread "main" java.lang.UnsatisfiedLinkError: no
     il2_core in java.library.path
             at java.lang.ClassLoader.loadLibrary(Unknown Source)
             at java.lang.Runtime.loadLibrary0(Unknown Source)
             at java.lang.System.loadLibrary(Unknown Source)
             at com.maddox.il2.engine.GObj.loadNative(GObj.java:143)
             at com.maddox.il2.engine.Config.<init>(Config.java:576)
             at com.maddox.il2.game.WConsole.beginApp(WConsole.java:227)
             at com.maddox.il2.game.WConsole.exec(WConsole.java:287)
             at com.maddox.il2.game.WConsole.main(WConsole.java:321)
     err:heap:HEAP_ValidateInUseArena Heap 40380000: in-use arena
     403bf160 next block has PREV_FREE flag

Hmm. So then I read the instructions :).

     $ wine GS_il2ServerLauncher.exe
produces a window which wants an IP address, but clicking "Download 
Info" found a server. I left username and password blank and clicked 
Login, selected a group and launched. This all seems to work fine, but 
(not having the game) I have no idea whether it then did the right 
thing. A (wine)console window came up saying such things as:

IL2 FB dedicated server v1.11 
         Sound: Native library (build 1, target - standard) loaded. 
                  RTS Version 2.1 
                           Core Version 2.0 
                                    1>mission LOAD net/dogfight/ 
3/1_Islands.mis BEGIN                            Loading mission 
net/dogfight/   3/1_Islands.mis...                              Load 
    Load static objects 

Mission: net/dogfight/   3/1_Islands.mis is Playing 
         >timeout 3600000 f gc.cmd 

          Memory: total(4915200) free(603240) 
                            Memory: total(4915200) free(616792) 
                                              Memory: total(4915200) 
free(616376)                                             >timeout 
3600000 f gc.cmd 

So it looks to me to be running fine, though obviously I can't test it 
While this is running, BTW, the other executables produce exactly the 
same output, but if I'm correctly reading the instructions, this is 
expected (and dependent upon configuration).
The application seems to include all the Java stuff it needs, but the 
idea of running it in a native Java VM does seem unlikely, given the 
number of .exe and .dll components.
Aneurin Price

More information about the wine-users mailing list